Rancher Operational Advisory: Attention All Rancher K3s Customers, DB bug requires upgrade

Follow
Table of Contents

Dear Rancher customer,

This is an operational advisory from Rancher Support to Rancher customers running K3s clusters.

Are you running K3s clusters?  If so, please read further

critical bug was recently discovered in the following K3s releases:

  • v1.19.3+k3s2

  • v1.18.10+k3s2

  • v1.17.14+k3s1

  • v1.17.13+k3s2

The bug can lead to objects being removed unexpectedly from K3s's database. When this occurs, these objects will no longer be available in the Kubernetes API. See rancher/kine#61 for more details.

What do you need to do?

The above versions should not be used for new clusters and existing clusters should be upgraded to one of the following releases made available today, where the bug has been fixed:

Does this bug impact clusters that are on RKE, RKE2, or Hosted Kubernetes?

No.  This bug is limited to K3s clusters only.

Questions?

Simply submit a request via this portal referencing this article and we will track and respond to your question as a Support Ticket.

Thanks,

Rancher Support Team

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Article is closed for comments.