Rancher Operational Advisory: Attention All Rancher 2.x Customers running Windows nodes on VMware

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Dear Rancher 2.x customer,

This is an operational advisory from Rancher Support to Rancher 2.x customers who are running Windows clusters.

Do you operate Windows worker nodes on VMware-based infrastructure?  If so, please read further

Rancher Support strongly advises either staying on your current stable 10.X.X version of VMWare Tools or upgrading directly to v11.0.6 or higher once it is available in vCenter.

What you need to know

There is a known issue in VMWare Tools version v11.0.0 to V11.0.5 that affects Docker engine for Windows.  The bug is capable of causing significant stability issues for Windows worker nodes in Rancher mixed clusters. One presentation of the bug is that each Windows worker node has all of the running Docker containers restarted every 30 minutes.

We have included the following information from a VMWare KB Article concerning this issue.

Symptoms

In 64-bit windows Guest VM, few 64-bit applications may crash (exit abruptly). The corresponding services for those executables may stop.
Few applications/services which are affected: Veritas NetBackup service / bpinetd.exe and Docker engine for Windows.

Cause

In VMware Tools 11.0.0, a new plugin called 'appInfo' was bundled. This new plugin runs every 30 minutes (can be configured by the guest administrator) to capture the information about running processes. For this, the plugin creates a remote thread in the target 64-bit process to capture the 'command line' of the target process. If the 64-bit application of the process is not built with '/LARGEADDRESSAWARE:YES, 'the remote thread' crashes the application.

Resolution

This issue is fixed in VMware Tools 11.0.6. For more information, see VMware Tools 11.0.6 Release Notes.

Workaround

To work around this issue, turn off the appinfo plugin inside the guest VM using vmwaretoolboxcmd.exe config set appinfo disabled true.

Questions?

Simply submit a request via this portal referencing this article and we will track and respond to your question as a Support Ticket.

Thanks,

Rancher Support Team

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