Issue
"rancher.zendesk.com refused to connect." error when attempting to sign in to the Rancher Customer Support portal
Root Cause
Third-party cookies are blocked in your browser settings.
Resolution
To fix this problem, third-party cookies will need to be enabled in your browser settings.
As a user, when you click on "SIGN IN", you will see the following message in the Sign in dialog box:
Click on the link that says, "Click here to restart your sign in."
If this action does not address the problem, then the browser setting will need to be modified manually.
In Google Chrome
- Go to the Preferences menu under Chrome
- Click on Privacy & Security
- Click on Cookies and site data
- Toggle the option Block third-party cookies off
In Mozilla Firefox
- Go to the Preferences menu under Firefox
- Click on Privacy & Security
- Under the Enhanced Tracking Protection section, check if it is set to Custom.
- If yes, check if "All third-party cookies (may cause websites to break)" is the selected value in the dropdown next to the Cookies checkbox.
- If yes, change it to "Cross-site and social media trackers".
- Click on the Reload All Tabs button
In Microsoft Edge
- Go to the Preferences menu under Microsoft Edge
- Click on Site Permissions
- Go to Cookies and site data
- Toggle the option Block third-party cookies off
In Apple Safari
Per this Zendesk article, below is the suggested resolution:
The latest version of the Apple Safari browser, Safari 13.1, fully blocks third-party cookies. If you are using a host-mapped domain for your Help Center, agents and end users cannot sign on with a Safari 13.1 browser. The only workarounds are to use incognito mode or try another browser.
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