How should I understand the kubernetes patch version mentioned in the support matrix under Rancher Kubernetes for a specific Rancher product version?

Follow
Table of Contents

Kubernetes versions are expressed as x.y.z, where x is the major version, y is the minor version, and z is the patch version, following Semantic Versioning terminology.

Where an upstream version x.y.z has been posted as supported in the support matrix, under Rancher Kubernetes, z is the highest patch version for that minor version (y) of Kubernetes, that has been tested and validated for the specific Rancher product version.

In the case of Rancher v2.3.4, the following are listed as the supported k8s upstream versions for Rancher Kubernetes:

  • v1.17.0
  • v1.16.4
  • v1.15.7

That is to say, the following are the k8s versions that are supported in Rancher v2.3.4:

  • v1.17.x (v1.17.0)
  • v1.16.x (v1.16.0-v1.16.4)
  • v1.15.x (v1.15.0-v1.15.7)

Note:

As described in this Rancher docs page, the RKE metadata feature—available as of v2.3.0—allows users to provision clusters with new versions of Kubernetes as soon as they are released, without upgrading Rancher.  For a specific version of Rancher, if a k8s patch version (z+i) that is higher than what is listed in the support matrix is available via a metadata refresh, then that patch version z+i is considered supported for that version of Rancher.

Also, see Could you help us understand the Rancher approach to supporting specific k8s versions and how Rancher keeps up with new k8s releases?

Was this article helpful?
1 out of 1 found this helpful

Comments

0 comments

Article is closed for comments.